Local development in Alan

I’m trying to work locally (offline) for Alan projects.

When I try to run Alan “build” / “fetch” I get this error.


To add more context
I initially followed the online documentation for offline editing. But the error I was getting was “failed to resolve Alan tool” when I run the “fetch or build” commands.
So I pushed Alan online IDE files and folders to Github and pulled it to my local machine. After which I did not encounter that error again.
Then I tried the “build and fetch” command and I get the error in the picture. What could possibly be the issue?

The alan script is a script that should be executable by your bash shell interpreter. I assume you run this from within Visual Studio Code.

Can you open a Terminal window within Visual Studio Code and let me know which shell interpreter is being used?

Yes, I’m using VS Code. The Windows PowerShell is my default interpreter.

The Alan scripts can not be run using PowerShell, so you should make sure they are being executed using bash. Try setting the Task Shell for Alan tasks to bash, like this:

The path of bash.exe can be different on our system. In this case we installed Git for Windows first.

Thanks very much it worked. I have to use the ./alan build in the terminal.